Authorize.net - Charges going through, no orders
Incident Report for Zoey
Postmortem
Posted 3 months ago. Jan 23, 2019 - 11:41 EST

Resolved
Summary of issue: Orders placed through Authorize.net on January 22, 2019 were charged but no order was created in Zoey

Cause of issue: Authorize.net made an undocumented change to how they send their responses back to the requester

Solution: We have updated our code to reflect how Authorize.net now sends their responses have rolled out a fix for it. Normal order processing through the Authorize.net payment gateway should now resume. All stores will have the fix by 7:30pm ET January 22, 2019.

Action You Should Take: All merchants who use Authorize.net must check their transactions starting on January 22, 2019 in Authorize.net (https://login.authorize.net/) to see whether there are any that appear in Authorize.net but do not appear in Zoey. If so, you will need to reach out to the customer directly to have them place the order again and void their transaction in Authorize.net. If you have no missing orders nothing needs to be done.

Post Mortem: Zoey was unable to foresee this issue as the matter was Authorize.net changing the response it sends back unexpectedly. This issue is extremely wide spread and affects platforms other than Zoey. We have built more robust handling of these unexpected changes to avoid future issues but anytime a third party response is changed unexpectedly, problems such as this can occur.

Thank you for your patience and understanding during this issue.
Posted 3 months ago. Jan 22, 2019 - 18:22 EST
Identified
Our Engineering Team has published an update that should Authorize.net send an invalid response, the order will still be created in Zoey.

Having said that, the "Transaction ID" will not be correct and you will not be able to create an online credit memo or capture the payment at a later time through the Zoey interface but you can do either of those actions within Authorize.net and manually log it to Zoey to have a record of it (if needed). If your Authorize.net Zoey Payment Settings are for Authorize&Capture then an invoice will automatically be created in Zoey.

If you disabled Authorize.net you can re-enable it now as transactions will go through and orders will be created in Zoey but with those two caveats in mind.

We continue to wait for an update from Authorize.net and will keep you updated as soon as we receive an update.
Posted 3 months ago. Jan 22, 2019 - 17:04 EST
Update
Customers have asked us when this problem began - we first received tickets about this at 3pm ET on January 22, 2019. We suggest you check your Authorize.net transaction logs for transactions that have no corresponding Zoey Order.

While we await an update from Authorize.net our technical team is attempting to build a workaround so that even if the response we get from Authorize.net is invalid (as it is now) the order object will still be created in Zoey. We will keep you updated as soon as more information becomes available.
Posted 3 months ago. Jan 22, 2019 - 16:26 EST
Investigating
We have received many reports of customers placing orders using the Authorize.net payment gateway where charges are being approved but no order record shows in Zoey.

We are aware of this issue and have reached out to our Partner Support at Authorize.net who has advised us that this is an incident they are investigating. There have been no modifications to the Zoey codebase with respect to the Authorize.net integration and Zoey is unable to fix this issue at the moment as the error appears to be with Authorize.net.

We are awaiting further updates from Authorize.net. We highly recommend disabling the Authorize.net Payment Gateway from your Zoey Store until this issue is resolved. We do not have a method of recreating these broken order objects and we do apologize for that.

We will post an update as soon as one is available. Thank you for your patience and your understanding.
Posted 3 months ago. Jan 22, 2019 - 16:14 EST
This incident affected: Zoey Global Connectivity.