Store Connectivity Issues
Incident Report for Zoey
Resolved
Connectivity to all stores should now be resolved, thank you for your patience as we investigated this issue.
Posted about 2 months ago. Aug 23, 2019 - 15:47 EDT
Investigating
We are currently investigating the inability to access Zoey Stores.
Posted about 2 months ago. Aug 23, 2019 - 15:40 EDT
This incident affected: Zoey Global Connectivity and Zoey Control Panel.