Cloudflare Global Outage

Incident Report for Zoey

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 09:52 EST

Update

We are continuing to monitor Cloudflare for a fix for this issue.
Posted Nov 18, 2025 - 09:01 EST

Identified

We are monitoring a global Cloudflare outage that is impacting services for Zoey including admin login access.

For more information see Cloudflare Status at www.cloudflarestatus.com
Posted Nov 18, 2025 - 07:00 EST
This incident affected: Zoey Global Connectivity, Zoey Control Panel, and Zoey Support.