Store Connectivity Issues
Incident Report for Zoey
Resolved
Connectivity has been restored to all Zoey Stores. Thank you for your patience.
Posted about 2 months ago. Aug 21, 2019 - 09:03 EDT
Investigating
We are currently investigating reports of inability to access Zoey Stores.
Posted about 2 months ago. Aug 21, 2019 - 08:55 EDT
This incident affected: Zoey Global Connectivity and Zoey Control Panel.