Store Connectivity
Incident Report for Zoey
Resolved
All Zoey Stores should now be accessible. If you experience any further issues please open a ticket at support.zoey.com
Posted 4 months ago. Jun 18, 2019 - 21:36 EDT
Identified
We are currently performing some emergency work, sites may be unavailable for a brief period of time. Thank you for your patience.
Posted 4 months ago. Jun 18, 2019 - 21:01 EDT
This incident affected: Zoey Global Connectivity.