Connectivity Outage
Incident Report for Zoey
Resolved
A fix has been deployed and all stores should be back online now. If you experience further issues please open a support ticket at https://support.zoey.com
Posted 5 months ago. May 21, 2019 - 13:13 EDT
Investigating
We are investigating reports of being unable to access Zoey Stores at this time.
Posted 5 months ago. May 21, 2019 - 12:58 EDT
This incident affected: Zoey Global Connectivity.